Скачать открытый исходный код бота Либре общий выпуск и установите бот Libre на свой собственный сервер
Bot Libre Forum

problem with my plant aiml script

по bobred опубликовано May 11 2017, 2:43

I have a problem with my chatbots plant aiml script.When i asked it a particular question the first time it answered correctly.Then when i asked it the question

the second time it would not answer correctly.Then it stopped answering correctly that particular question.It won't answer some of question correctly even

though the answers are in the my plant aiml script.What is going on?Here is my script.my plants.aiml.txt


by admin posted May 11 2017, 7:19
I added your plant script to your bot "Blair" and it works.

In general you can import AIML either as a response (which is heuristically matched) or as a script (which is executed programmatically).

If you add it as a response the bot will avoid using the same response twice in a row, so will find another response.

If you add it as a script the bot will always use the same response.

Also, check that you do not have learning enabled, otherwise you will be corrupting your bot's responses.

Also, you had a "?" in your AIML pattern. In general AIML patterns should not contains punctuation, if they do it will be required for the pattern to match. Normally punctuation is ignored when matching a pattern.

Thumbs up: 0, thumbs down: 0, stars: 0.0
Views: 1017, today: 1, week: 1, month: 1

by bobred posted May 11 2017, 13:18

Learning is not enabled.Thankyou that worked.I would like to make a guessing game next for blair.I will try to do that.


Thumbs up: 0, thumbs down: 0, stars: 0.0
Views: 1008, today: 2, week: 2, month: 3

Идентификатор: 16997310
Опубликовано: May 11 2017, 2:43
Ответы: 2
Вид: 1044, сегодня: 1, неделю: 1, месяц: 2
Я уверен, что
Вывесить флаг как оскорбительное, или в нарушение правил сайта